import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!PAYROLL\\s)(FIDELITY(?!.*TITLE)(?!.*NATION)|INVEST)(?!.*PAYROLL)";
final String string = "INCOMING WIRE TRUST GS INVESTMENT \n"
+ "VANGUARD PAYROLL\n"
+ "PAYROLL FIDELITY\n"
+ "ACH CREDIT FIDELITY INVESTM-FIDELITY\n"
+ "ACH CREDIT FIDELITY INVESTM-FIDELITY\n"
+ "ACH DEBIT FIDELITY \n"
+ "ACH DEBIT FIDELITY \n"
+ "ACH CREDIT FIDELITY INVESTM-FIDELITY\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}