#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)PAYROLL\s+FIDELITY(*SKIP)(*F)|(FIDELITY(?!.*TITLE)(?!.*NATION)|INVEST)(?!.*PAYROLL)"
Local $sString = "INCOMING WIRE TRUST GS INVESTMENT " & @CRLF & _
"VANGUARD PAYROLL" & @CRLF & _
"PAYROLL FIDELITY" & @CRLF & _
"ACH CREDIT FIDELITY INVESTM-FIDELITY" & @CRLF & _
"ACH CREDIT FIDELITY INVESTM-FIDELITY" & @CRLF & _
"ACH DEBIT FIDELITY " & @CRLF & _
"ACH DEBIT FIDELITY " & @CRLF & _
"ACH CREDIT FIDELITY INVESTM-FIDELITY" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")