// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<p>(.*)<\/p>").unwrap();
let string = "<?xml version=\"1.0\" encoding=\"utf-8\"?>
<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.1//EN\"
\"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd\">
<html xmlns=\"http://www.w3.org/1999/xhtml\" xml:lang=\"en\">
<head>
xxxx
<meta http-equiv=\"Content-Type\" content=\"text/html; charset=UTF-8\"/>
<meta name=\"calibre:cover\" content=\"true\"/>
<title>Cover</title>
<style type=\"text/css\" title=\"override_css\">
@page {padding: 0pt; margin:0pt}
body { text-align: center; padding:0pt; margin: 0pt; }
</style>
</head>
<body>
<div>
<svg xmlns=\"http://www.w3.org/2000/svg\" xmlns:xlink=\"http://www.w3.org/1999/xlink\" version=\"1.1\" width=\"100%\" height=\"100%\" viewBox=\"0 0 566 734\" preserveAspectRatio=\"none\">
<p>
1
2
3
4
5
</p>
<image width=\"566\" height=\"734\" xlink:href=\"../Images/cover.jpeg\"/>
yyyy
</svg>
</div>
</body>
</html>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}