const regex = /(\d{1}[[:punct:]]\s*\[){1}(.*\s*\{)(.*\s*\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1}[[:punct:]]\\s*\\[){1}(.*\\s*\\{)(.*\\s*\\])', 'g')
const str = `1.
[Lorem ipsum dolor sit amet, consectetur adipiscing elit. Etiam mauris lectus, lobortis vitae semper vitae, molestie in tellus. Etiam fermentum quam quis posuere pharetra. Morbi id erat id ante consequat tincidunt. Ut et lorem hendrerit, euismod tortor ac, blandit ligula. In fermentum, tellus quis dignissim interdum, ante mi malesuada turpis, rutrum maximus sem magna vel ante. Etiam maximus lacinia augue nec scelerisque. Aliquam euismod lectus ante, eget fringilla sem pretium ac. Sed eu ex tempor, eleifend dolor nec, semper sem...
{B:rnbqkbnr/pppppppp/8/8/8/8/PPPPPPPP/RNBQKBNR w KQkq - 0 1}{W:L5_lectus ante}
]
2.
[Lorem ipsum dolor sit amet, consectetur adipiscing elit. Etiam mauris lectus,
Lobortis vitae semper vitae, molestie in tellus. Etiam fermentum quam quis posuere pharetra.
Morbi id erat id ante consequat tincidunt.
{B:rnbqkbnr/pppppppp/8/8/8/8/PPPPPPPP/RNBQKBNR w KQkq - 0 1}{S:e2e4}{D:1000}{S:e7e6}{D:5000}{S:d2d4}{S:d7d5}{D:1000}{S:b1c3}{S:1000}{A:Tc3e4}{D:3000}{R}{S:g8f6}{D:1000}{S:e4e5}{D:1000}{S:f6d7}{W:L5_G1_C110}{W:L5_G1_C001}{W:L5_G1_C002}{W:L5_G1_C003}{W:L5_G1_C004}
]
3.
[Lorem ipsum dolor sit amet, consectetur adipiscing elit. Etiam mauris lectus, lobortis vitae semper vitae, molestie in tellus.
Etiam fermentum quam quis posuere pharetra. Morbi id erat id ante consequat tincidunt.
Ut et lorem hendrerit, euismod tortor ac, blandit ligula. In fermentum, tellus quis dignissim interdum, ante mi malesuada turpis, rutrum maximus sem magna vel ante. Etiam maximus lacinia augue nec scelerisque. Aliquam euismod lectus ante, eget fringilla sem pretium ac.
Sed eu ex tempor, eleifend dolor nec, semper sem...
{B:rnbqkb1r/pppn1ppp/4p3/3pP3/3P4/2N5/PPP2PPP/R1BQKBNR w KQkq - 0 1}{D:5000}{G:BPc7}{S:c7c5}{D:2000}{S:c5c7}{X:c7}{P:BPc7}{D:3000}{S:f2f4}{D:5000}{S:c7c5}{D:4000}{S:d4c5}{D:1000}{S:b8c6}{W:L5_G1_C005}{W:L5_G1_C006}{W:L5_G1_C007}
]
4.
[Lorem ipsum dolor sit amet, consectetur adipiscing elit. Etiam mauris lectus, lobortis vitae semper vitae, molestie in tellus. Etiam fermentum quam quis posuere pharetra. Morbi id erat id ante consequat tincidunt. Ut et lorem hendrerit, euismod tortor ac, blandit ligula. In fermentum, tellus quis dignissim interdum, ante mi malesuada turpis, rutrum maximus sem magna vel ante. Etiam maximus lacinia augue nec scelerisque. Aliquam euismod lectus ante, eget fringilla sem pretium ac. Sed eu ex tempor, eleifend dolor nec, semper sem...
{B:r1bqkb1r/pp1n1ppp/2n1p3/2PpP3/5P2/2N5/PPP3PP/R1BQKBNR w KQkq - 0 1}{D:1500}{S:a2a3}{D:9000}{A:Ta3b4}{D:2000}{R}{A:Wb2b4}{D:3000}{R}{S:f8c5}{W:L5_G1_C008}
]
5.
[Lorem ipsum dolor sit amet, consectetur adipiscing elit. Etiam mauris lectus, lobortis vitae semper vitae, molestie in tellus.
Etiam fermentum quam quis posuere pharetra. Morbi id erat id ante consequat tincidunt. Ut et lorem hendrerit, euismod tortor ac, blandit ligula. In fermentum, tellus quis dignissim interdum, ante mi malesuada turpis, rutrum maximus sem magna vel ante. Etiam maximus lacinia augue nec scelerisque.
Aliquam euismod lectus ante, eget fringilla sem pretium ac. Sed eu ex tempor, eleifend dolor nec, semper sem...
{B:r1bqk2r/pp1n1ppp/2n1p3/2bpP3/5P2/P1N5/1PP3PP/R1BQKBNR w KQkq - 0 1}{D:3000}{S:d1g4}{D:2000}{A:Dg4g7}{H:g7}{D:5000}{R}{C}{D:3000}{S:g7g6}{D:10000}{S:g1f3}{D:2500}{S:a7a6}{D:2000}{A:Bb7b5}{D:4000}{R}{S:f1d3}{D:2000}{S:b7b5}{W:L5_G1_C009}{W:L5_G1_C010}{W:L5_G1_C011}{W:L5_G1_C012}{W:L5_G1_C013}{W:L5_G1_C014}
]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}