re = /(<[^ ]+?>)/m
str = '<test>
jakis tekst omijany
<to>
ten tez omijany
</to>
</test> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end