const regex = /.*&AppliedWhenID=(\d+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*&AppliedWhenID=(\\d+).*', 'gm')
const str = `ReportType=233&ReportConID=171&MonthQuarterYear=0TimePeriodLabel=Year%202020&AppliedWhenID=2
ReportType=233&ReportConID=171&MonthQuarterYear=0TimePeriodLabel=Year%202020&AppliedWhenID=2&AgDateTypeID=1
ReportType=233&ReportConID=171&MonthQuarterYear=0TimePeriodLabel=Year%202020&AppliedWhenID=2123&AgDateTypeID=1
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);