$re = '/[\r\n]([\r\n]+)/m';
$str = 'A
B
C
D';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;