const regex = /[\r\n]([\r\n]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\r\\n]([\\r\\n]+)', 'gm')
const str = `A
B
C
D`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);