import re
regex = re.compile(r"^(?:(?!(?:not allowed|filter|mirc)).)*?(?:http:\/\/|www\.|porn|credit card)(?:(?!(?:not allowed|filter|mirc)).)*$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("http://porn.filter\n"
"http://porn.com\n")
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)