$re = '/[]/m';
$str = 'I bet you can\'t match [] using regex!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);