$re = '/(?<!Mr\. )([A-Z]\w{4,})/m';
$str = 'Mr. Brown, Ms. Smith, Mrs. Jones, Miss Daisy, Mr. Green';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);