re = /(?<=Feb )([1-2][0-9])|(?<=Mar )([1-2][0-9]|3[0-1])/m
str = 'Dates worked: Feb 28, Feb 29, Feb 30, Mar 30, Mar 31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end