package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:exact|else)wo`)
var str = `exact else exactwo elsewo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}