using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|,)\s*(\""[^"",]*\""|[^"", ]*)";
string input = @"a, ""b"", ""c d"",e,f, ""g h"", dfgi,, k, "", l";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}