$re = '/(he([a-z])(\2+))/m';
$str = 'heyabcdefg hey heyo heyellow heyyyyyyyyy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);