package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)t`)
var str = `t t t t`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}