package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w*o\w*`)
var str = `The quick brown fox jumps over the lazy dog.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}