package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9A-F][0-9A-F][0-9A-F]`)
var str = `1H8 4E2 8FF 0P1 T8B 776 42B G12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}