$re = '/[^aeiou]/m';
$str = 'The walls in the mall are totally, totally tall.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);