package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^d-w]`)
var str = `abcdefg h.i,j-klmnopqrstuvwxyz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}