package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\[nrt]`)
var str = `\`\n\`, \`\r\`, \`\t\`, and \`\f\` are whitespace characters, \`\.\`, \`\\\` and \`\[\` are not.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}