package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z_$]\w*`)
var str = `__e $123 3.2 fo Barr a23mm ab x`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}