$re = '/ca[rt]/m';
$str = 'The cat was cut when it ran under the car.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);