package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\.*\d*[KMGT]B`)
var str = `1..3KB 5...GB ..6TB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}