using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"dog|cat|pet";
string input = @"Obviously, a dog is a better pet than a cat.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}