import re
regex = re.compile(r"(\d*\.\d+[fF]|\d+\.\d*[fF]|\d+[fF])|(\d+[lL])", flags=re.MULTILINE)
test_str = "42L 12 x 3.4f 6l 3.3 0F L F .2F 0."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")