re = /([A-Z][a-z]?[a-z]?)|([A-Z][a-z][a-z][a-z]+)/m
str = 'Kim Jobs Xu Cloyd Mohr Ngo Rock'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end