package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]{18,}`)
var str = `humuhumunukunukuapua'a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}