package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"[^"]{0,5}\"|\"[^"]+\s[^"]*\"`)
var str = `"12345" "my password" "Xanadu.2112" "su_do" "OfSalesmen!"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}