package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^start|end$`)
var str = `start end start end start end start end`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}