$re = '/ba[rt]/m';
$str = 'A bat, a cat, and a rat walked into a bar...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);