re = /(?:name's (\w+))[^J]+\1/m
str = '"Hi my name\'s Joe." [later] "What\'s that guy\'s name? Joe?"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end