package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PAN-OS ver:\s*(?<PAN_OS_VER>[^ ]+)\s+Panorama ver:(?<Software_Version>[^ ]+)`)
var str = `Client authentication successful PAN-OS ver: 9.1.11-h3 Panorama ver:10.1.6-h3 Client IP: 10.68.196.211 Server IP: 10.58.217.123 Client CN: 013101004861
Client authentication successful PAN-OS ver: 9.1.11 Panorama ver:10.1.6-h6 Client IP: 10.58.90.53 Server IP: 10.58.90.200 Client CN: 010401005346`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}