// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)My dog's name is (.*)\.").unwrap();
let string = "
Sally said, \"My dog's name is Fido.\"
Billy replied, \"I have a cat named Spot.\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}