re = /^(last|previous|next|down)(.*?)(word[s]?|line[s]?|sentence[s]?|paragraph[s]?|para[s]?|char[s]?|character[s]?|space|\n\n|\n)$/m
str = 'previous2word
last5paras
next10characters
lastspace'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end