const regex = /^([а-яА-ЯA-Za-zёЁ0-9]{2})\.([а-яА-ЯA-Za-zёЁ0-9]{2})\.([а-яА-ЯA-Za-zёЁ0-9]{3})$/mu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([а-яА-ЯA-Za-zёЁ0-9]{2})\\.([а-яА-ЯA-Za-zёЁ0-9]{2})\\.([а-яА-ЯA-Za-zёЁ0-9]{3})$', 'mu')
const str = `d1.df.dfd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}