re = /((?<=(?:["]))[^"].*?(?=["]))/m
str = '"you can" use single or \'double\' quote"there are\'"Z"""z""""what"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end