re = /((?:\w+\.)+\w+)/
str = '(options.method==="
|options.method==="
=options.method==="HEAD"
options.method.options.method==="HEAD"'
subst = '<span class="join">$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result