$re = '/^\S*(?=\S{12,25})(?=\S*[a-z])(?=\S*[A-Z])(?=\S*[\d])\S*$/m';
$str = '012345678901234567890123456789aA
КоличествоСимволoвTутБольше25НеТакЛи?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);