using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\s\w+\s(\w+).*\+(\d+)";
string input = @"Johnny Alan Walker Sint Jansstraat 7, 1012 HG Amsterdam +123456789012";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}