re = /\/.*?(?={|\/)\/?|{.*?}/
str = '/part-of-{INTERESETINGSTUFF}/an-url/{MORESTUFF}
/hey/{hi}/hey/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end