#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0[0-9]{2}\*{6}[0-9]{2}$"
Local $sString = "# Test data" & @CRLF & _
"# Corrects" & @CRLF & _
"079******56" & @CRLF & _
"" & @CRLF & _
"# Errors" & @CRLF & _
"079*****56" & @CRLF & _
"079*******56" & @CRLF & _
"079**-****56" & @CRLF & _
"79******56" & @CRLF & _
"709******56" & @CRLF & _
"0793*****56" & @CRLF & _
"079*****456" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")