re = /^(?=[^tf]|t[^r]|tr[^u]|true[a-zA-Z0-9]|f[^a]|fa[^l]|fal[^s]|false[a-zA-Z0-9])[a-zA-Z][a-zA-Z0-9]+$/
str = 'true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end