$re = '/^((?!.*[Ð×Þß÷þø])(?![ \'-])[-\'a-zA-ZÀ-ÿŒœ ]{0,100})(?<![ \'-])$/s';
$str = 'aßßa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);