import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\s*define\\s*(\\(.*?\\))";
final String string = "#lang sicp\n"
+ "(define (square x) (* x x))\n"
+ "(define (average x y) (/ (+ x y) 2))\n\n\n"
+ "; using block scope\n"
+ "(define (sqrt x)\n"
+ " ; x is always the same -- \"4\" or whatever we pass to it, so we don't need that\n"
+ " ; in every single function that we define, we can just inherit it from above.\n"
+ " (define (improve guess) (average guess (/ x guess)))\n"
+ " (define (good-enough? guess) (< (abs (- (square guess) x)) 0.001 ))\n"
+ " (define (sqrt-iter guess) (if (good-enough? guess) guess (sqrt-iter (improve guess))))\n"
+ " (sqrt-iter 1.0)\n"
+ ")\n"
+ "(sqrt 4)\n\n"
+ "(define (inc x) (+ x 1))\n"
+ "(define (dec x) (- x 1))\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}