re = /^(\S \S{1}(?=\s)|\S(?= \S{2})|\{\S\}|\w{3}(?=\w))/m
str = '1 {2 3}
1 2 3
1 23
{1}
{1 2}
123456 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end