# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<[Rr]epresentation[^>]*?[Bb]andwidth=\"0?[2-9]\d{6}\"[\s\S]*?[Rr]epresentation>"
test_str = ("<MPD xmlns=\"urn:mpeg:dash:schema:mpd:2011\" minBufferTime=\"PT1.500000S\" type=\"static\" mediaPresentationDuration=\"PT0H9M54.00S\" profiles=\"urn:mpeg:dash:profile:isoff-live:2011\">\n"
" <ProgramInformation moreInformationURL=\"http://gpac.sourceforge.net\">\n"
" <Title>/home/elkhatib/Documents/dash264/TestCases/2b/qualcomm/2_BBB_5Sec_MainProf/MultiRes.mpd generated by GPAC</Title>\n"
" </ProgramInformation>\n"
" <Period id=\"\" duration=\"PT0H9M54.00S\">\n"
" <AdaptationSet segmentAlignment=\"true\" maxWidth=\"1280\" maxHeight=\"720\" maxFrameRate=\"24\" par=\"16:9\">\n"
" <Representation id=\"1\" mimeType=\"video/mp4\" codecs=\"avc1.4d401f\" width=\"512\" height=\"288\" frameRate=\"24\" sar=\"1:1\" startWithSAP=\"1\" bandwidth=\"2000000\">\n"
" <SegmentTemplate timescale=\"12288\" duration=\"61440\" media=\"BBB_512_640K_video_$Number$.mp4\" startNumber=\"1\" initialization=\"BBB_512_640K_video_init.mp4\" />\n"
" </Representation>\n"
" <Representation id=\"1\" \n"
"mimeType=\"video/mp4\" \n"
"codecs=\"avc1.4d401f\" \n"
"width=\"512\" \n"
"height=\"288\" \n"
"frameRate=\"24\" \n"
"sar=\"1:1\" \n"
"startWithSAP=\"1\" \n"
"bandwidth=\"1000000\">\n"
" <SegmentTemplate timescale=\"12288\" duration=\"61440\" media=\"BBB_512_640K_video_$Number$.mp4\" startNumber=\"1\" initialization=\"BBB_512_640K_video_init.mp4\" />\n"
" </Representation>\n"
" <Representation id=\"1\" mimeType=\"video/mp4\" codecs=\"avc1.4d401f\" width=\"512\" height=\"288\" frameRate=\"24\" sar=\"1:1\" startWithSAP=\"1\" bandwidth=\"2000000\">\n"
" <SegmentTemplate timescale=\"12288\" duration=\"61440\" media=\"BBB_512_640K_video_$Number$.mp4\" startNumber=\"1\" initialization=\"BBB_512_640K_video_init.mp4\" />\n"
" </Representation>\n"
" <Representation id=\"2\" mimeType=\"video/mp4\" codecs=\"avc1.4d401f\" width=\"768\" height=\"432\" frameRate=\"24\" sar=\"1:1\" startWithSAP=\"1\" bandwidth=\"4000000\">\n"
" <SegmentTemplate timescale=\"12288\" duration=\"61440\" media=\"BBB_768_1440K_video_$Number$.mp4\" startNumber=\"1\" initialization=\"BBB_768_1440K_video_init.mp4\" />\n"
" </Representation>\n"
" </AdaptationSet>\n"
" </Period>\n"
"</MPD>\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.