$re = '/{+(\d*?)}/';
$str = 'this an example with {2} words and {7} numbers';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);