import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+|\\S+\\s+\\d+\\s+\\S+) (\\S+) ?sendmail\\[\\d+\\]: (\\S+): ?(\\S+)? \\[(\\d+\\.\\d+\\.\\d+\\.\\d+)] ?(\\(may be forged\\))? did not issue MAIL\\/EXPN\\/VRFY\\/ETRN during connection to M(?:TA|SA)$";
final String string = "Aug 20 04:44:21 hostname sendmail[40746]: v7K8iDNm040746: host2.example.com [10.11.101.202] (may be forged) did not issue MAIL/EXPN/VRFY/ETRN during connection to MSA";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}