package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^[]*)\[([\d]*)\]$`)
var str = `contracts[4]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}